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LABVIEW 

 

Experiment No:  1. INTRODUCTION TO LABVIEW 
 

Objective:To learn the LABVIEW Basics and get familiar with LABVIEW commands. 

Equipments Required: LABVIEW (software) 

Overview of  LABVIEW 

LabVIEW (Laboratory Virtual Instrumentation Engineering  Workbench) is a platform and developm

ent environment for a visual programming language from National Instruments. The graphical langua

ge  is  named  "G".  LabVIEW  is  commonly  used  for  data  acquisition,  instrument  control,  and in

dustrial  automation  on  a  variety  of  platforms  including  Microsoft  Windows,  various  flavors  of 

 UNIX, Linux, and Mac OS.   

One  benefit  of  LabVIEW  over  other  development  environments  is  the  extensive  support  for  a

ccessing instrumentation  hardware.  Drivers  and  abstraction  layers  for  many  different  types  of  i

nstruments  and buses  are  included  or  are  available  for  inclusion.  These  present  themselves  as  

graphical  nodes.  The abstraction  layers  offer  standard  software  interfaces  to  communicate  with  

hardware  devices.  The provided  driver  interfaces  save  program  development  time.  Many  librari

es  with  a  large  number  of functions for data acquisition, signal generation, mathematics, statistics, 

signal conditioning, analysis, etc., 

along  with  numerous  graphical  interface  elements  are  provided  in  several  LabVIEW  package  

options. Another benefit of the LabVIEW environment is the platform independent nature of the G‐co

de (LabVIEW programming  language),  which  is  (with  the  exception  of  a  few  platform‐specific 

 

functions) portable  between the different LabVIEW systems for different operating systems (Window

s, MacOSX and Linux).   

Dataflow  

The programming language used in LabVIEW, called "G", is a dataflow language. Execution is  

determined by the structure of a graphical block diagram (the LV‐source code) on which the program

mer connects different function‐nodes by drawing wires. These wires propagate variables and any nod

e can execute as soon  as  all  its  input  data  become  available.  Since  this  might  be  the  case  for  

multiple  nodes simultaneously, G is inherently capable of parallel execution.   

Screenshot of a simple LabVIEW program that generates, synthesizes, analyzes and displays wavefor

ms, showing  the  block  diagram  and  front  panel.  Each  symbol  on  the  block  diagram represents 

a  LabVIEW subroutine (subVI) which can be another LabVIEW program or a LV library function.  
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Graphical programming LabVIEW ties the creation of user interfaces (called front panels) into the de

velopment cycle. LabVIEW programs/subroutines  are  called  virtual  instruments  (VIs).  Each  VI  h

as  three  components:  Each  VI contains three main parts:  

  

           1. Front Panel ‐ How the user interacts with the VI.  

           2. Block Diagram ‐ The code that controls the program.  

           3. Icon/Connector ‐ Means of connecting a VI to other VIs.  

         

The Front Panel is the user interface of the VI, to interact with the user when the program is running.  

Users can control the program, change inputs, and see data updated in real time. You build the front p

anel with  controls  and  indicators  (available  on  the  Control  Palette),  which  are  the interactive  in

put  and output terminals of the VI, respectively. Controls are knobs, pushbuttons, dials, and other  

input devices.  

Indicators are graphs, LEDs, and other displays.   

  

Controls simulate instrument input devices and supply values to the block diagram of the VI.  

Indicators simulate  instrument  output  devices  and  display  values  the  block  diagram  acquires  or 

 

generates.  These may  include  data,  program  states,  and  other  information.  Every  front  panel  co

ntrol  or  indicator  has  a corresponding terminal  on  the  block  diagram.  When  a  VI  is run,  values

  from  controls  flow  through  the block diagram, where they are used in the functions on the diagram

, and the results are passed into other  

functions or indicators. The  Controls  palette  is  available  only  on  the  front  panel.  Go  to  Windo

w»Show  Controls  Palette  or right‐click the front panel workspace to display the Controls palette.  
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The Block Diagram contains this graphical source    

code.  Front  panel  objects  appear  as  terminals  on   the block diagram. Additionally, the block diag

ram  contains  functions  and  structures  from  built‐in  

 

LabVIEW  VI  libraries.  These  can  be  accessed  from  the  Functions  Palette.  Wires  connect  each

  of  the 

nodes on  the block  diagram,  including  control  andindicator terminals, functions, and structures. 

 

 

 
 
 
The Functions palette is available only on the block diagram.  Select  Window»Show  Functions  Pale

tte or  right‐click  the  block  diagram  workspace  to display the Functions palette The  Icon/Connecto

r  may  represent  the  VI  as  a  subVI  in  block  diagrams  of  calling  VIs.  Controls  and indicators o

n the front panel allow an operator to input data into or extract data from a running virtual instrument. 

 

However,  the  front  panel  can  also  serve  as  a  programmatic  interface.  Thus  a  virtual instrumen

t  can  either  be  run  as  a  program,  with  the  front  panel  serving  as  a  user  interface, or, when dr

oppedas a node onto the block diagram, the front panel defines the inputs and outputs for the given no

de through the connector pane. This implies each VI can be easily tested before being embedded as a s

ubroutine into a larger program.  

The  graphical  approach  also  allows  non‐programmers  to  build  programs  by  simply  dragging  a

nd dropping  virtual  representations  of  the  lab  equipment  with  which  they  are  already  familiar. 

 

The LabVIEW programming environment, with the included examples and the documentation, makes
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 it easy to  create  small  applications.  For  complex  algorithms  or  large‐scale  code  it  is  important 

 

that  the programmer  possess  an  extensive  knowledge  of  the  special  LabVIEW  syntax  and  the  

topology  of  its memory  management.  The  most  advanced  LabVIEW  development  systems  offer

  the  possibility  of  building stand alone application.The other 

features  that  you  will  need  include  the  Tools  Palette  which  is  a  Floating  Palette  that  is  used  

to operate  and  modify  front  panel  and  block  diagram  objects  and  the  Status  Toolbar.  They  co

ntain  the following tools and buttons  respectively.  
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Exercise 1 ­ Open and Run a Virtual Instrument  
Examine the signal feneration processing VI and run it. Change the frequency and types of 
the input signals and notice how the display on the graph changes. Change the signal 
processing window and filter options. After you have changed the VI and other options, you 
can change , stop the VI processing by pressing stop button . 

1. Select  Start»Programs»National  Instruments»LabVIEW  7.0»LabVIEW  to  launch  
LabVIEW.  

        The LabVIEW dialog box appears.  
          
        
2.  Select  Help»Find  Examples.  The  dialog  box  that  appears  lists  and  links  to  all  avail
able  
        LabVIEW example VIs.  
          
        
3.  On  the  Browse  Tab,  select  browse  according  to  task.  Choose  Analyzing  and  Proces
sing  
        Signals, then Signal Processing, then Signal Generation and Processing.vi.  
        This will open the Signal Generation and Processing VI Front Panel.  
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 Experiment No:  2. Building a VI & Modifying a Signal  
 

Objective: To learn the LABVIEW Basics and get familiar with LABVIEW commands. 

Equipments Required: LABVIEW (software) 

Building a VI  

Beforebuilding our own VI we will first examine the Signal Generation and Processing VI an
d 
 run it.  Change the frequencies and types of the input signals and notice how the display on t
he graph changes.  
Change  the  Signal  Processing  Window  and  Filter  options.  After  you  have  examined  th
e  VI  and  the different options you can change, stop the VI by pressing the Stop button. 
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Block Diagram  
  
        8. Select Window»Show Diagram or press the <Ctrl‐E> keys to display  
        the block diagram for the Signal Generation and Processing VI.  
          
        
This  block  diagram  contains  several  of  the  basic  block  diagram  elements,  including  su
bVIs,       functions, and structures, which you will learn about later in this course.  
          
        9. Select Window»Show Panel or press the <Ctrl‐E> keys to return to the Front Panel.  
          
        10. Close the VI and do not save changes.  
 
 
Creating Your Own VI: 
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Note: Block  Diagram  terminals  can  be  viewed  as  icons  or  as  terminals.     
To  change  the  way LabVIEW displays these objects right click on a terminal and select  
View As Icon.    
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15 
 

Exercise 4 – Using Loops  
Use a while loop and a waveform chart to build a VI that demonstrates software timing. 
Front Panel  
1. Open a new VI.  
2. Build the following front panel.  
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12. 
Right‐click  the  waveform  chart  and  select  Data  Operations»Clear  Chart  from  the  short
cut     menu  to  clear  the  display  buffer  and  reset  the  waveform  chart.  If  the  VI  is  run
ning,  you  can  select Clear Chart from the shortcut menu.  
 
Adding Timing  
When this VI runs, the While Loop executes as quickly as possible. Complete the following s
teps to take  data at certain intervals, such as once every half‐second, as shown in the followi
ng block diagram . 
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a. Place the Time Delay Express VI located on the Functions»Execution Control palette. 
In the dialog box that appears, insert 0.5. This function would make sure that each 
iteration occers every half-second(500ms). 

b. Divide the millisecond delay by 1000 to get time in seconds.  Connect the output of th
e       divide function to the Delay Time (s) input of the Time Delay Express VI.  This 
will allow  
           
you to adjust the speed of the execution from the pointer slide on the front panel.  
 
 
 
13. Save the VI, because you will use this VI later in the course. 
14. Run the VI. 
15. Try different values for the millisecond delay and run the VI again. Notice how 
this effects the speed of the number generation and display. 
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2. Modifying a Signal 
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Displaying Two Signals on a Graph 

 

 

 
 
Customizing a Knob Control  
The  knob  control  changes  the  amplitude  of  the  saw 
tooth  wave,  so  labeling  it  Amplitude  accurately  
describes  the  behavior  of  the  knob.  Complete  the  following  steps  to  customize  the  appearance
  of  the  
knob.  
1. On the front panel, right‐click the knob and select  Properties from the shortcut menu to display  
       the Knob Properties dialog box.  
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  Experiment No. 3: Exercises in Lab VIEW 
 
 
  
  
Exercise 1 ­ Using Waveform Graphs  

  
Front Panel  
  

1. Open a new VI and build the following front panel using the following tips.  
  

                                                                              
     
a. Create a waveform graph indicator from the Controls»Graph Indicators palette. Use the  
   position/size/select tool to move the plot legend to the side, and expand it to display two  
   plots. Use the labeling tool to change the plot names and the properties page to choose  
   different colours for your plots.  
b. Place a Stop button on the front panel.  
c. Place two vertical pointer slides from the Controls»Numeric Controls palette. Use the  
   properties page again to change the slide fill colour.  

  
  
  
  
  
  
  
  
  

 



25
 

Block Diagram  
  

2. Build the following block diagram.  
  

a. 
b. 

c. 

d. 

  

  
Place a While Loop from Functions» Execution Control palette.   
Place a Wait Until Next ms Multiple from Functions»All Functions »Time & Dialog and  
create a constant with a value of 100.  
Place two Simulate Signal Express VIs from the Functions»Input and leave the Signal type  
as Sine for the first Simulate Signal VI and change the Signal Type to Square for the second  
VI. Wire both of the outputs into the waveform graph.  A Merge Signals function will  
automatically be inserted.  
Expand the Simulate Signal Express VIs to show another Input/Output.  By default, error  
out should appear.  Change this to Frequency by clicking on error out and choosing  
Frequency.  

  

3. Save the VI as Multi-plot Graph.vi.  
  
4. Display the front panel and run the VI.  
         
5. Save and close the VI.  
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Exercise 2 ­ Error Clusters & Handling  

  

  

Front Panel  
1. Open a new VI and build the following front panel using the following tips.  
  

  
a. Create a numeric control and change the Label to Square Root Input.  Create a numeric indicator  
   for Square Root.  
b. Place Error In 3D.ctl from Controls»All Controls»Arrays & Clusters.  
c. Place Error Out 3D.ctl from Controls» All Controls»Arrays & Clusters.  

  

  

  
Block Diagram  
  

2. Build the following block diagram.  

                                                           
  
a. Place a Case Structure from Functions»Execution Control palette.   
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b. Place a Greater or Equal to 0? from the Functions»Arithmetic and  
   Comparison»Comparison palette and wire it to the condition terminal of the case structure.  
  

  
In the True Case:  
        c. Place the Square Root function from Functions»Arithmetic and Comparison»Numeric  
            palette.  
          
In the False Case:  

                                                                                 
        d. Create a numeric constant from Functions»Arithmetic and Comparison»Numeric palette  
            and type ‐9999.90.  
        e. Place the Bundle By Name from Functions»All Functions»Arrays & Clusters palette. Wire  
            from Error in to the center terminal of Bundle by Name to make status show up.  Create  
            constants.  Wire from the Error Out indicator to the output of Bundle By name.  
          
3. Save the VI as Square Root.vi.  
4. Display the front panel and run the VI.  
5. Save and close the VI.  
  

End of Exercise  
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Exercise 3­ Simple State Machine  
  
Create a VI using state machine architecture that simulates a simple test sequence. The VI will have an initial state,  
where it will display a pop‐up message indicating that it is starting the test.  Then it will proceed to the next case  
and then to the final state where it will ask the user whether to start over or end the test.  
  
Front Panel  

Rather than start from scratch, we will use a VI template to create our state machine.   
  
1. From the initial LabVIEW screen click on New…, and choose Standard State Machine, which is located  
   under the VI from Template » Frameworks » Design Patterns heading.  
2. Examine the template, and then save it in another directory before you begin working on it.  
  
  

Block Diagram  
  

3. Right click on the enum constant labeled Next State and select Open Type Def.  
4. On the front panel of the StateMachinesStates.ctl Type Def VI, right click on the States enum control and  
   choose Edit Items.  
5. Add two more states.  Call them “State 1” and “State 2”  
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6. Close the State Machines.ctl Type Def Front panel and save the control with the default name when  
   prompted.  
7. Right click on the Case Selector Label of the case structure and choose Duplicate case.  Do this one  
   additional time so that there are four cases: Initialize, State 1, State 2, and Stop.  

  

  
8. Change the value connected to the Wait function to 2000.  

  
  

  

9. Right click on the shift register on the left side of the while loop and create an indicator.  Change it’s  
    name to “Current State”.  
10. In the “Initialize”, Default case place a One Button Dialog function and wire a string constant into the  
    Message input.  Type “Now beginning test…” into the string constant.  

  

                                                      
11. Change the enum constant labled Next State to “State 1”.  
12. Change to the next state in the case structure (“State 1”) and change the enum constant labled Next  
    State to “State 2”.  
13. Change to the next state (“State2”) and add the following code.  
        a. Place a Select function and connect two enum constants  
        (Tip:  Copy the enum constants from one of the previous cases)  
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b. Place a Two Button Dialog and wire create the constants as illustrated below.  
  
  

  
        
      14. Run the VI.  
      15. Save and close the VI.  
        
End of Exercise  
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  Experiment No.4: Data Acquisition  
 
Objective:To learn the data acquisition technique using LABVIEW. 

Equipments Required: LABVIEW (software) 

 
 

  

  
The NI USB 6009 multifunction I/O is a device that can be used to connect LabVIEW to external devices  
for  Data  Acquisition.  The  NI  USB‐6009  is  a  USB  based  data  acquisition  (DAQ)  and  control  device  with  
analog input and output and digital input and output.   
  
The main features of NI USB‐6009 are as follows:  
  
    • Analog  input  (AI):  8  inputs  with  referenced  single  ended  signal  coupling  or  4  inputs  with  
        differential  signal  coupling.  Software‐configurable  voltage  ranges:  ±20V,  ±10V,  ±5V,  ±4V,  ±2.5V,  
        ±2V, ±1.25V, ±1V. Max sampling rate is 48kS/s (48000 samples per second). 14 bits AD converter  
        (USB‐6008: 12 bits).   
• Analog  output  (AO):  2  outputs.  Voltage  range  is  0  to  5V  (fixed).  Output  rate  is  150Hz  
        (samples/second). 12 bits DA converter.   
• Digital  input  (DI)  and  digital  output  (DO):  12  channels  which  can  be used as  either  DI  or  DO  
        (configured individually). These 12 channels are organized in ports, with Port 0 having lines 0, .., 7,  
        and Port 1 having lines 0, .., 3. Input low is between 0.3V and +0.8V. Input high is between 2.0V  
        and +5.8V. Output low is below 0.8V. Output high is above 2V (with open‐drain and push‐pull as  
        options).   
• Counter: 32 bits: Counting on falling edge.   
• On­board voltage sources (available at individual terminals): 2.5V and 5.0V   
• Power: USB 6009 is powered via the USB cable.   
• Configuring and testing: USB6009 can be configured and tested using MAX (Measurement and  
        Automation Explorer) 4.0, which is installed with NI‐DAQ 8.0.   
• Application software: LabVIEW, C, or Visual Studio.  
• Platforms: Windows, Mac, Linux.   

 
 Data Acquisition   

  

        Installing the DAQ  
After  inserting  the  CD,  the  NI‐DAQmx  7.x  installer  should  open  automatically.  If  not,  select  Start»Run.  
Enter  x:\setup.exe,  where  x  is  the  letter  of  the  CD  drive.  Complete  the  instructions  in  the  installer,  
including  rebooting  the  computer  if  necessary.  For  troubleshooting  instructions,  refer  to  the  Hardware  
Installation/Configuration Troubleshooter at ni.com/support/install.  
  
Note: Install your driver software  before installing new hardware devices, so Windows can detect your  
device.  
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After  installing  the  software,  the  actual  device  should  be  installed.  This  is  done  quite  easily  by  simply  
plugging in the USB cable into PC and device, and then click  Next on any dialog that appears. Next click  
Finish.  
  
Note USB­6008/6009 Only—If this is the first time that a USB‐6008/6009 device is  
installed on your computer, you might be prompted to install a USB‐6xxx Firmware  
Loader. Please complete the Windows Hardware Wizard prompts to completely install this device.  
  
Device Confirmation  
  
Complete the following steps:  
    1. Double‐click the Measurement & Automation icon on the desktop to open MAX.  
    2. Expand Devices and Interfaces, then expand NI­DAQmx Devices.  
  
          

  

  

  

  

  

  

  

  
  

3. Check  that  your  device  appears  under  Devices  and  Interfaces.  If  your  device  does  not  appear,  
   press  <F5>  to  refresh  the  view  in  MAX.  If  the  device  is  still  not  recognized,  refer  to  
   ni.com/support/install for troubleshooting information.  
4. Right‐click your device and select Self­Test.  

  
If  you  need  help  during  the  self‐test,  select  Help»HelpTopics»NI­DAQmx  and  click  Max  Help  for  NI­ 
DAQmx. When the self‐test finishes, a message indicates successful verification or if an error occurred.  
  
You  can  also use  a test  panel for testing specific device functionality, such  as the ability to acquire and  
generate signals. It can be done as follows:  
     1. In MAX, expand Devices and Interfaces»NI­DAQmx Devices.  
     2. Right‐click the device to test.  
     3. Select Test Panels to open a test panel for the selected device.  
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4. Click  Start  to  test  different  functions  of  the  device.  Click  Help  for  instructions  on  operating  the  
   test panels.  
5. The test panel displays a message indicating whether an error occurred.   

  
  
To see the terminals of the  USB‐6009, select Device   Pinouts in the menu shown below. The terminals  
or pins are shown in the NI‐DAQmx  
Device  Terminals window.  
  
The  DAQ  is  now ready  to  connect  
external  devices  to LabVIEW.   
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Exersise :  
Reading a analog signal from a signal generator and displaying in Labview.  
  
The purpose of this exersice is to teach you how to build a LabVIEW application to retrieve voltage input  
values using the NI USB‐6009 data acquisition device.  
  
   1. Click “New VI” button to create a new blank LabVIEW program   
   2. Select Front Panel and enable Controls Palette to choose a “Waveform Chart” indicator in “Graph”  
       group, add to front panel and name it “Voltage”.  
   3. Switch to Block Diagram to verify that a new data terminal was created (named “Voltage”).  
   4. In  the  Block  diagram,  open  the  Functions  Palette  to  get  the  DAQ  Assistant.  The  path  goes  as  
       Functions>>Express>>Input>>DAQ Assistant.   
       Note:  If you have any trouble  in finding a  block use the Search function available just below the  
       Title Bar of the Functions Palette.  
   5. When the DAQ Assistant is placed in the Block diagram window, a window with  “Cretae New…” in  
       the title bar appears. Select Analog Input and then Voltage.  
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6. The Physical Tab will appear showing the  devices attached and the corresponding pins.  Select the  
   required pin and click Finish.  
7. Another DAQ Assistant window will appear. Under the Voltage Input setup, Settings Tab select the  
   appropriate maximum & minimum input signal range and units.(preferably, ‐5 to 5 volts). Also, in  
   the Task Timing Tab under Acquisition mode select 1 Sample (On Demand).Click OK.  

  
  

  
  
  
  

  
8. Connect the data output from the DAQ Assistant to the Waveform chart terminal, using the wiring  
    tool. If the wiring tool does not appear automatically on moving the cursor over the Data output of  
    DAQ, go to View>>Tools Palette and select the wiring tool.  To make wiring easier, you can invoke  
    the  Help  window  to  support  it.  The  Help  window  shows  input  and  output  parameters  of  each  
    selected VI. (The way to display the Help window is to click on the Help menu selection and select  
    the “Show Context Help” option)   
9. You  can  change  the  window  to  the  Front  Panel  window  and  click  the  “Run”  (or  “Run  
    Continuously”) button to execute the VI.  
10. If your waveform chart does not show the whole graph, you can change the scale of the Yaxis. To  
    change the Y axis scale on the waveform chart, move the cursor to the graphic origin, click the left  
    mouse button, and type in the desired value  
11. The “Run Continuously” button executes the VI continuously. You can also add a “While Loop” to  
    enhance your program. First, move mouse to the Block Diagram. Open the Functions Palette and  
    select  the  Structures  group  and  then  the  While  Loop.  Add  the  While  Loop  to  the  Block  Diagram  
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    and enlarge it to include the DAQ Assistant and the Voltage Waveform data terminal. On the front  
    panel add a Stop button (from Controls>>Boolean>>Stop Button) to control the execution of the  
    While Loop. In the block diagram, wire the stop button of the front panel to the stop button of the  
    while loop.  
12. After wiring, switch to Front Panel and press the RUN button to execute the VI.  

  
  
  
  

  
  
  
  
  
  
  
  
  
Make  sure  that  all  your  external  wiring  is  connected  properly  and  all  devices  have  a  common  
ground.  

  
  
     Exersise :  

Sending an analog signal from the NI USB 6009 and displaying in a Oscilloscope.  
  
The purpose of this exersice is to teach you how to build a LabVIEW application to send voltage outputs  
values from NI USB 6009 data acquisition cards.   
  
   1. Click “New VI” button to create a new blank LabVIEW program  
   2. Select Front Panel and enable Controls Palette to choose a “Waveform Chart” indicator in “Graph”  
       group, add to front panel and name it “Voltage”.  
   3. Switch to Block Diagram to verify that a new data terminal was created (named “Voltage”).  
   4. In  the  Block  diagram,  open  the  Functions  Palette  to  get  the  DAQ  Assistant.  The  path  goes  as  
       Functions>>Express>>Input>> DAQ Assistant.   
       Note:  If you have any trouble  in finding a  block use the Search function available just below the  
       Title Bar of the Functions Palette.  
   5. When the DAQ Assistant is placed in the Block diagram window, a window with  “Cretae New…” in  
       the title bar appears. Select Analog Output and then Voltage.  
   6. The Physical Tab will appear showing the devices attached and the corresponding pins. Select the  
       required pin and click Finish.  
   7. Another DAQ Assistant window will appear. Under the Voltage Output setup, Settings Tab select  
       the  appropriate  maximum  &  minimum  input  signal  range  and  units.(preferably,  0  to  10  volts).  
       Also, in the Task Timing Tab under Acquisition mode select 1 Sample (On Demand).Click OK.  
   8. Generate a sinusoidal signal using the express VI using the “Simulate sig” express VI. The path to  
       access  these  “Functions”  >>  Express>>  “Inputs”  >>    “Simulate  sig”.  Select  a  type of  signal,  its  
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amplitude  and  frequency.  Select  a  number  of  “samples  per  second”  as  1000  and  uncheck  the  
    automatic for number of samples and select “1” as number of samples. Now connect the output of  
    “Simulate sig” to the voltage input of the DAQ Assistant.  
9. Also connect the Voltage waveform to the output of “Simulate sig”.  
10. Complete your wiring and run to see the result in your graph as well as the oscilloscope.  
11. The “Run Continuously” button executes the VI continuously. You can also add a “While Loop” to  
    enhance your program. First, move mouse to the Block Diagram. Open the Functions Palette and  
    select  the  Structures  group  and  then  the  While  Loop.  Add  the  While  Loop  to  the  Block  Diagram  
    and enlarge it to include the DAQ Assistant and the Voltage Waveform data terminal. On the front  
    panel add a Stop button (from Controls>>Boolean>>Stop Button) to control the execution of the  
    While Loop. In the block diagram, wire the stop button of the front panel to the stop button of the  
    while loop.  
12. After wiring, switch to Front Panel and press the RUN button to execute the VI.  

  
Make  sure  that  all  your  external  wiring  is  connected  properly  and  all  devices  have  a  common  
ground.  
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Exercise: Traffic Light  
  
Construct a  VI  that  will  display  a  traffic  light  in the  Front  Panel.  See  figure below. Light  transitions  are  
timed. Let red take 2s, yellow 1s and green 3s. Try to utilize your knowledge of LabVIEW in constructing  
this VI.  
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Exercise: Filling and emptying a Tank  
  
Build  a  VI  that  display  a  Front  Panel  similar  to  which  shown  below.  The  front  panel  should  have  a  
Numeric Control to set a desired tank level. The filling and emptying tasks should be displayed gradually.  
Your VI should decide by itself if it is to fill or to empty the tank. An OK button is to start the task.  
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  Experiment No. 5: Digital Input / Output 
 

Objective:To learn sending and receive Digital Signals using  LABVIEW commands. 

Equipments Required: LABVIEW (software) 

 
Digital  signals  are  digital  representations  of  discretetime  signals,  which  are  often  derived  from  analog  
signals. An analog signal is a datum that changes over time—say, the temperature at a given location; the  
depth of a certain point in a pond; or the amplitude of the voltage at some node in a circuit—that can be  
represented as a mathematical function, with time as the free variable (abscissa) and the signal itself as  
the  dependent  variable  (ordinate).  A  discrete‐time  signal  is  a  sampled  version  of  an  analog  signal:  the  
value of the datum is noted at fixed intervals (for example, every microsecond) rather than continuously.  
  
If  individual  time  values  of  the  discrete time  signal,  instead  of  being  measured  precisely  (which  would  
require  an  infinite  number  of  digits),  are  approximated  to  a  certain  precision—which,  therefore,  only  
requires  a  specific  number  of  digits—then  the  resultant  data  stream  is  termed  a  digital  signal.  The  
process of approximating the precise value within a fixed number of digits, or bits, is called quantization.  
In  conceptual  summary,  a  digital  signal  is  a  quantized  discrete‐time  signal;  a  discrete‐time  signal  is  a  
sampled analog signal.  
  
In most applications, digital signals are represented as binary numbers, so their precision of quantization  
is  measured  in  bits.  Suppose,  for  example,  that  we  wish  to  measure  a  signal  to  two  significant  decimal  
digits. Since seven bits, or binary digits, can record 128 discrete values (viz., from 0 to 127), those seven  
bits are more than sufficient to express a range of one hundred values.  
  
Exercise: Sending and receiving digital signals  
  
The  purpose  of  this  exercise  is  to  teach  you  how  to  build  a  LabVIEW  application  to  send  and  receive  
digital values from NI USB 6009 data acquisition cards.   
  
• Part 1: Sending  
     1. Click “New VI” button to create a new blank LabVIEW program  
     2. Select  Front  Panel  and  enable  Controls  Palette  to  choose  a  “Push  Button”  indicator  in  “Boolean”  
         group  (you  can  also  use  a  toggle  or  slide  switch,  etc.  as  well),  add  to  front  panel  and  name  it  
         “Status”.  
     3. Switch to Block Diagram to verify that a new data terminal was created (named “Status”).  
     4. In  the  Block  diagram,  open  the  Functions  Palette  to  get  the  DAQ  Assistant.  The  path  goes  as  
         Functions>>Express>>Input>> DAQ Assistant.   
     5. When the DAQ Assistant is placed in the Block diagram window, a window with “Create New…” in  
         the title bar appears. Select Digital I/O and then Line Output.  
     6. The Physical Tab will appear showing the devices attached and the corresponding pins. Select the  
         required pin(s) and click Finish.  
     7. Another DAQ Assistant window will appear. Under the Task Timing Tab under Acquisition mode  
         select 1 Sample (On Demand).Click OK.  
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• 

8. If you want to send more than 1 signal at a time, then first put more Boolean switches/buttons on  
    the front panel. In the Block diagram, connect all the Boolean terminals into one using “Functions”  
>>  Programming>>  “Arrays”  >>  “Build  arrays”.  Extend  the  size  of  the  array  according  to  the  
    number of signals to send.  
9. Next  connect  the  array  output  to  the  data  pin  of  the  DAQ  assistant.  Note:  Make  sure  that  the  
    correct pin numbers are assigned to the Boolean switches in the DAQ Assistant.  
10. You  can  also  add LEDs  (from  Controls>>Boolean)  and  connect  them  to  the  switches  in  the block  
    diagram if you want to view the result on the front panel as well.  
11. The “Run Continuously” button executes the VI continuously. You can also add a “While Loop” to  
    enhance your program.   
12. After wiring, switch to Front Panel and press the RUN button to execute the VI.  

   Part 2: Receiving  
For testing Digital input,   
   - Select Digital I/O>>Line Input in the DAQ assistant   
   - And instead of Boolean switches use LEDs.   
   - Also Index array can be used.   
  
Note:  In  hard  wire,  real  LEDs  and  switches  can  be  used  for  demonstration.  Make  sure  that  all  your  
external wiring is connected properly and all devices have a common ground.  
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Good Luck! 
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